User Password Issues

Started by Marina at Jul 31, 2020 12:29 pm
303 Views
7 Posts

Marina

0
27Years Young
21 Posts

So! More issues popped up today, this time more password issues.

Basically what happens is this:

 

- User registers for an account. All is ok!

- User tries to login with password and gets "incorrect password" error

- Admin resets password from admin panel.

- Password works now!

- User goes to change their password.

- Logs out later, then goes to login again. Password doesn't work.

- IF user set a recovery question, user can go through recovery steps and reset password.

- Reset password WORKS.

 

Basically what I'm seeing is that if someone chooses their own password from the user panel, the system decides that password doesn't work. But when it's reset with the system (either by admin doing or done by recovering password), the password works.


Marina

0
27Years Young
21 Posts

Also if it helps at all: "last seen" when first registering doesnt seem to work

https://gyazo.com/489960b5697fb8a76506435503b53c41


Arceus

codemancer
0
30Years Young
75 Posts

They don't think that I listen, oh but I know who they are.


This is a browser-based problem, when a user's browser automatically fills in the password field, the password will reset itself on profile save. Most likely what I will do is in Salerno the password resetting area will be separate from the rest of the profile so that editing the profile doesn't trigger a password reset (which by the way should mean the password is blank).

In the meantime, tell your players to either turn off auto-fill or remember to de-fill in their password field when they're editing their profile.


Marina

0
27Years Young
21 Posts

I'm not sure if it's a browser issue. I just changed browsers (which has no autofill on) and tested it on an account and made sure the password wasn't filled in. Changed the password and upon changing password, my new password did not work. Had to go through to recover my password to get a working password.


Arceus

codemancer
0
30Years Young
75 Posts

They don't think that I listen, oh but I know who they are.


Did you install the latest version of Vesta?


Marina

0
27Years Young
21 Posts

I believe so. Vesta Athens 1.0.1


Arceus

codemancer
0
30Years Young
75 Posts

They don't think that I listen, oh but I know who they are.


I'll have a look at the files in the version that's up, then, I may not have applied the temp fix.